Transaction delivery service degradation
Incident Report for Orderful
Resolved
Transaction delivery service is back to a healthy state. The incident is now resolved. Please email support@orderful.com if you have any questions.
Posted Jul 18, 2022 - 20:25 UTC
Investigating
We are currently investigating an issue that is impacting transaction delivery.
Posted Jul 18, 2022 - 20:08 UTC
This incident affected: Transaction Delivery (Trading Partner Delivery Services).