Delayed transaction delivery
Incident Report for Orderful
Resolved
The incident is now resolved and the transaction delivery service is back to a healthy state. Please reach out to support@orderful.com if you are still experiencing any issues or have questions.
Posted Apr 13, 2022 - 21:01 UTC
Investigating
We are currently investigating an incident impacting transaction delivery. Transaction delivery is delayed.
Posted Apr 13, 2022 - 20:28 UTC
This incident affected: Transaction Delivery (Trading Partner Delivery Services).