Email delivery service
Incident Report for Orderful
Resolved
The incident is now resolved and email delivery service is back to a healthy state. Please email support@orderful.com if you have questions.
Posted Apr 27, 2022 - 19:09 UTC
Investigating
We are currently investigating an incident that is impacting outgoing email delivery service.
Posted Apr 27, 2022 - 18:53 UTC
This incident affected: Mailjet Email Content.