Transaction Processing Degradation

Incident Report for Orderful

Resolved

All unprocessed transactions have been reprocessed.
Incoming processing is happening in real-time.
The issue is resolved and a long-term mitigation fix is beginning.
Posted Jul 31, 2025 - 16:15 UTC

Monitoring

A fix is in place and transaction processing is much healthier with the vast majority of traffic unaffected. Some endpoints are responding slowly but gradually improving and we are continuing to monitor.
Posted Jul 31, 2025 - 15:41 UTC

Identified

We're currently aware of an issue causing transaction processing to be consumed at slower rate than incoming traffic. We're investigating the root cause and at the same time expanding resources to brute force.
Posted Jul 31, 2025 - 15:12 UTC
This incident affected: API.