Creating transactions impacted
Incident Report for Orderful
Postmortem

During a brief window between 2:01 PM PST and 2:15 pm PST a configuration issue caused some HTTP requests to POST /v2/transactions to be incorrectly rejected with a 4xx status code. System wide the total number of rejected transactions was < 100, however we are unable to differentiate between the incorrectly rejected requests and ones which should have been correctly rejected so the total number of requests rejected incorrectly could be less.

If your company did experience any outbound transaction failures during this time, simply repost your transactions if you have not already done so. All requests will be handled correctly. During this incident, data integrity was maintained, no transactions were lost, and no inbound transactions were impacted.

Posted Nov 10, 2020 - 17:14 UTC

Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 00:18 UTC
Monitoring
An issue with data migration resulted in failures of requests between 2:01 p.m. and 2:15 p.m. PST. Requests to v2/transactions would have returned status 400 errors. Data integrity was maintained, no transactions were lost and all client requests which returned success status code processed correctly.
Posted Nov 09, 2020 - 23:45 UTC
This incident affected: API.