Accessing www.orderful.com
Incident Report for Orderful
Resolved
www.Orderful.com Is back up and running.
Posted Apr 25, 2023 - 18:58 UTC
Investigating
We are currently experiencing an issue with www.orderful.com. Our team is working to resolve the issue as quickly as possible. In the meantime, please note that https://ui.orderful.com is still operational and available for use. Our platform is also still working, and we are actively monitoring the situation to ensure that all other aspects of our service remain unaffected. We apologize for any inconvenience this may cause and will provide updates as soon as they become available. Thank you for your patience and understanding.
Posted Apr 25, 2023 - 17:01 UTC